Production of official page.
Incident Report for Sudobank Status
Resolved
This incident has been resolved.
Posted Apr 30, 2020 - 12:10 GMT-03:00
Update
We are continuing to monitor for any further issues.
Posted Apr 20, 2020 - 12:07 GMT-03:00
Monitoring
Production of official page.

For competitive reasons, we removed our landing page to produce a new one that fits the defined visual standard.

The page will only return when everything is ready to be released.
Posted Apr 20, 2020 - 12:06 GMT-03:00
This incident affected: Web Hosting Page.